[PATCH] D67140: [analyzer][NFC] Fix inconsistent references to checkers as "checks"

Alexander Kornienko via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Wed Sep 4 06:24:39 PDT 2019


alexfh added a reviewer: aaron.ballman.
alexfh added a comment.

In D67140#1656858 <https://reviews.llvm.org/D67140#1656858>, @gribozavr wrote:

> Thanks! Yay consistency.
>
> I prefer the term "checker" to refer to individual modules because I feel it is more precise and less ambiguous. In phrases like "malloc check", "make_unique check", it is unclear what does the check -- malloc itself, the caller of malloc, or something else. Therefore, I would be supportive of repainting ClangTidy to also use "checker", but I would want to know what @alexfh thinks about it before we do it in ClangTidy.


Historically, clang-tidy only used the term "check" (to denote the thing that checks something, rather than the rule being checked or the act of checking), and we tried to keep its use consistent. However, "checker" is a more precise and less ambiguous way to convey this meaning. I support to use the term "checker" in clang-tidy, as long as someone is willing to update the code and documentation (except for verbs, e.g. the `check()` method ;). Also note that there's a non-trivial number of out-of-tree check(er)s out there. They will need to be updated as well.

Adding Aaron in case he has a different opinion.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D67140/new/

https://reviews.llvm.org/D67140





More information about the cfe-commits mailing list