[PATCH] D62738: [HIP] Support device_shadow variable

Yaxun Liu via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Jun 24 11:57:49 PDT 2019


yaxunl marked an inline comment as done.
yaxunl added inline comments.


================
Comment at: include/clang/Basic/Attr.td:955
+def CUDADeviceShadow : InheritableAttr {
+  let Spellings = [GNU<"device_shadow">, Declspec<"__device_shadow__">];
+  let Subjects = SubjectList<[Var]>;
----------------
tra wrote:
> In light of the details you've provided below, perhaps this needs a better name. I've suggested `__device_shadow__` without being aware of what exactly it's supposed to do in HIP.  
> Perhaps something like `__hip_device_shadow__` or `__hip_pinned_shadow` ? Naming is hard. :-)
I think `__hip_pinned_shadow__` best describes such variables. I will update the patch to adopt it.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D62738/new/

https://reviews.llvm.org/D62738





More information about the cfe-commits mailing list