[PATCH] D61454: [CodeGen][ObjC] Remove the leading 'l_' from ObjC symbols and make private symbols in the __DATA segment internal.

Vedant Kumar via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Thu May 2 11:33:57 PDT 2019


vsk added a comment.

Thanks for working on this!



================
Comment at: lib/CodeGen/CGObjCMac.cpp:1983
+  else
+    GV->setSection("__OBJC,__cstring_object,regular,no_dead_strip");
+
----------------
Are constant NSStrings within the shared cache ever dirtied? I was under the impression that they couldn't be, so I'm not sure there's an advantage to making them internal.


================
Comment at: lib/CodeGen/CGObjCMac.cpp:3113
+  return CreateMetadataVar("_OBJC_PROTOCOLEXT_" + PD->getName(), values,
+                           StringRef(), CGM.getPointerAlign(), true, false);
 }
----------------
Could you use '/*ExplicitDataSegment=*/false' (or similar) for clarity here and elsewhere?


Repository:
  rC Clang

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D61454/new/

https://reviews.llvm.org/D61454





More information about the cfe-commits mailing list