[PATCH] D57986: [ProfileData] Sort FuncData before iteration to remove non-determinism

David Blaikie via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri Mar 1 16:19:24 PST 2019


dblaikie accepted this revision.
dblaikie added inline comments.
This revision is now accepted and ready to land.


================
Comment at: lib/ProfileData/InstrProfWriter.cpp:431-432
+  for (const auto &record : OrderedFuncData) {
+    const auto &name = record.first;
+    const auto &Func = record.second;
+    writeRecordInText(name, Func.first, Func.second, Symtab, OS);
----------------
Inconsistent variable naming? (some start with upper case, some with lower case)

Currently I think the LLVM style says upper case is required.

Naming the types here might be reasonable for readability, but I'm not sure.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D57986/new/

https://reviews.llvm.org/D57986





More information about the cfe-commits mailing list