r207829 - CodeGen: rename __builtin_arm_sevl to __sevl
kongy.dev at gmail.com
Mon Jun 23 15:00:50 PDT 2014
On 23 June 2014 18:09, Saleem Abdulrasool <abdulras at fb.com> wrote:
> On Jun 23, 2014, at 9:33 AM, Yi Kong <kongy.dev at gmail.com> wrote:
>> Saleem Abdulrasool <compnerd at ...> writes:
>>> Author: compnerd
>>> Date: Fri May 2 01:53:57 2014
>>> New Revision: 207829
>>> URL: http://llvm.org/viewvc/llvm-project?rev=207829&view=rev
>>> CodeGen: rename __builtin_arm_sevl to __sevl
>>> ACLE adds the __sevl() extension. Rename the hint from a custom name to
>>> ACLE specified name.
>> The renaming breaks the naming convention for Clang built-in intrinsics.
>> Every target-specific intrinsic should begin with __builtin_ArchName.
>> __sevl should be defined to __builtin_arm_sevl in arm_acle.h file.
> Sorry, I guess that I should have added more context into the commit message. This was discussed on IRC between Tim, Joey, Renato, and I. The ACLE defines the spelling to be __sevl, and since the change wasn’t there for very long, we decided that we would use the proper spelling. __sevl is already in a reserved namespace for the system, and providing an official extension symbol in that namespace is fine.
ACLE defines the spelling in the arm_acle.h header file instead of the
Since I'm currently working on the ACLE header file, I think it would
be best to stick to the conventional naming and map __sevl to
__builtin_arm_sevl in arm_acle.h.
>> cfe-commits mailing list
>> cfe-commits at cs.uiuc.edu
> Saleem Abdulrasool
> abdulras (at) fb (dot) com
More information about the cfe-commits