r207829 - CodeGen: rename __builtin_arm_sevl to __sevl

Saleem Abdulrasool abdulras at fb.com
Mon Jun 23 10:09:40 PDT 2014

On Jun 23, 2014, at 9:33 AM, Yi Kong <kongy.dev at gmail.com> wrote:

> Saleem Abdulrasool <compnerd at ...> writes:
>> Author: compnerd
>> Date: Fri May  2 01:53:57 2014
>> New Revision: 207829
>> URL: http://llvm.org/viewvc/llvm-project?rev=207829&view=rev
>> Log:
>> CodeGen: rename __builtin_arm_sevl to __sevl
>> ACLE adds the __sevl() extension.  Rename the hint from a custom name to 
> the
>> ACLE specified name.
> The renaming breaks the naming convention for Clang built-in intrinsics. 
> Every target-specific intrinsic should begin with __builtin_ArchName.
> __sevl should be defined to __builtin_arm_sevl in arm_acle.h file.

Sorry, I guess that I should have added more context into the commit message.  This was discussed on IRC between Tim, Joey, Renato, and I.  The ACLE defines the spelling to be __sevl, and since the change wasn’t there for very long, we decided that we would use the proper spelling.  __sevl is already in a reserved namespace for the system, and providing an official extension symbol in that namespace is fine.

> _______________________________________________
> cfe-commits mailing list
> cfe-commits at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits

Saleem Abdulrasool
abdulras (at) fb (dot) com

More information about the cfe-commits mailing list