r194095 - Produce direct calls instead of alias to linkonce_odr functions.

Chandler Carruth chandlerc at google.com
Tue Nov 12 13:04:51 PST 2013


On Tue, Nov 12, 2013 at 6:18 AM, Rafael EspĂ­ndola <
rafael.espindola at gmail.com> wrote:

> > So, what's going on here? Any ideas? Hopefully Nick can add a test case
> when
> > the reduction finishes.
>
> In hindsight the change to use a weak_odr alias to a linkonce_odr
> destructor was a bad hack around not having comdats. GCC always puts
> D1 and D2 in a comdat when they alias, but having direct comdat
> support means it can use a new name for the comdat, which avoid
> problems when mixing old and new object files.


Alternatively, rather than replacing one hack with another hack that may or
may not break ABI, why not actually implement comdat support?

I feel like this patch doesn't solve any pressing need, and is causing
gratuitous fallout. It may be that the old pattern was a hack, but it was
at least a hack that had been well tested in deployment and has caused us
no problems so far.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20131112/6d81143a/attachment.html>


More information about the cfe-commits mailing list