[Parallel_libs-commits] [PATCH] D24464: [SE] Clean up device and host memory slices
Jason Henline via Parallel_libs-commits
parallel_libs-commits at lists.llvm.org
Mon Sep 12 09:37:23 PDT 2016
jhen created this revision.
jhen added a reviewer: jlebar.
jhen added subscribers: parallel_libs-commits, jprice.
* Add LLVM_ATTRIBUTE_UNUSED_RESULT used to slicing methods in order to
emphasize that the slicing is not done in place.
* Change device memory slice function name from `drop_front` to `slice`
in order to match the naming convention of `llvm::ArrayRef` and host
memory slice.
* Change the parameter names of host memory slice functions to
`DropCount` and `TakeCount` to match device memory slice declarations.
https://reviews.llvm.org/D24464
Files:
streamexecutor/include/streamexecutor/DeviceMemory.h
streamexecutor/include/streamexecutor/HostMemory.h
streamexecutor/unittests/CoreTests/DeviceTest.cpp
streamexecutor/unittests/CoreTests/StreamTest.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D24464.71025.patch
Type: text/x-patch
Size: 8157 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/parallel_libs-commits/attachments/20160912/238910d2/attachment.bin>
More information about the Parallel_libs-commits
mailing list