[Parallel_libs-commits] [PATCH] D23333: [StreamExecutor] Add basic Stream operations

Jason Henline via Parallel_libs-commits parallel_libs-commits at lists.llvm.org
Fri Aug 12 13:17:48 PDT 2016


jhen added inline comments.

================
Comment at: streamexecutor/include/streamexecutor/PlatformInterfaces.h:42
@@ +41,3 @@
+/// Platform-specific stream handle.
+class PlatformStream {
+public:
----------------
jlebar wrote:
> If Stream is still calling into PlatformSE to do its work (so this class is just an RAII thing), maybe PlatformStreamHandle would be a better name?
Yes, that is a better name. I made the change.

================
Comment at: streamexecutor/include/streamexecutor/StreamExecutor.h:30
@@ -26,1 +29,3 @@
 public:
+  StreamExecutor();
+  StreamExecutor(PlatformStreamExecutor *PlatformExecutor);
----------------
jlebar wrote:
> What does it mean to have an SE without a backing PlatformSE?
I just forgot to delete this ctor during development. It is gone now.


https://reviews.llvm.org/D23333





More information about the Parallel_libs-commits mailing list