[Openmp-commits] [PATCH] D124652: [OpenMP] [OMPT] [amdgpu] [5/8] Implemented device init/fini/load callbacks
Michael Halkenhäuser via Phabricator via Openmp-commits
openmp-commits at lists.llvm.org
Fri May 5 10:55:47 PDT 2023
mhalk added inline comments.
================
Comment at: openmp/libomptarget/plugins-nextgen/common/PluginInterface/PluginInterface.h:27
#include "Utilities.h"
+#include "omp-tools.h"
#include "omptarget.h"
----------------
dhruvachak wrote:
> Guard it with OMPT_SUPPORT?
Yes, absolutely.
================
Comment at: openmp/libomptarget/plugins-nextgen/common/PluginInterface/PluginInterface.h:760
+ /// Internal representation for OMPT device (initialize & finalize)
+ std::atomic<bool> OmptDevice;
+#endif
----------------
dhruvachak wrote:
> Give it a more meaningful name, it's just an atomic boolean now. Some OMPT APIs require an opaque ompt_device_t. In the previous version, we would pass a handle to OmptDevice for those APIs, so that may have to refactored when the time comes.
Check w.r.t. "API" and I'd tend to sth. like `OmptInitialized`, since we're already looking at a "Device" this should convey the fact that we're looking at a boolean that's true when this device's OMPT relatied init has been executed.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D124652/new/
https://reviews.llvm.org/D124652
More information about the Openmp-commits
mailing list