[Openmp-commits] [PATCH] D135162: [OPENMP] New api ompx_get_team_procs(devid)
Greg Rodgers via Phabricator via Openmp-commits
openmp-commits at lists.llvm.org
Mon Oct 17 20:41:54 PDT 2022
gregrodgers added a comment.
I think I get your rational now. A thread executes on a places proc. In fact many threads can execute on (map to) a place proc. We need the same sort of "mapping" for a team or thread group. We did not call a place a thread_proc.
As the name is now, a team_proc is a place where a team can run, That can be a CU, an SM, a VE, a host socket, a host numa domain, a node, or something. The code in this review covers all existing (in trunk) offload plugins that can execute a team.
So I am still searching for the right term. The term would fill in the blank on these two sentences. A place is to a thread as a _____ is to a team. One or more treads execute on a places proc, whereas one or more teams executes on a _______ proc.
The current thread API is omp_get_place_num_procs(int place_num). The new ompx API for this review should be something like omp_get_NEWTERM_num_procs(int device).
I am open to suggestions.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D135162/new/
https://reviews.llvm.org/D135162
More information about the Openmp-commits
mailing list