[Openmp-commits] [PATCH] D135162: [OPENMP] New api ompx_get_team_procs(devid)

Johannes Doerfert via Phabricator via Openmp-commits openmp-commits at lists.llvm.org
Mon Oct 17 10:33:41 PDT 2022


jdoerfert added a comment.

As @tianshilei1992 noted, the naming is not great. Team can technically map to lots of things and soon they will. What about "thread groups"? Or even "sockets"?
Also, there is some duplication I pointed out below.



================
Comment at: openmp/libomptarget/include/device.h:325
+  /// for AMD, this is number of CUs. Field used by ompx_get_team_procs(devid).
+  int32_t TeamProcs;
 
----------------
It's unclear why we need to store this in two places, the plugins and here. Other device data only lives in the plugins, this should too.


================
Comment at: openmp/libomptarget/plugins/cuda/src/rtl.cpp:356
   std::vector<std::vector<CUmodule>> Modules;
+  std::vector<int> NumberOfTeamProcs;
 
----------------
This should go into DeviceData, and in the new plugin interface it's different again.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D135162/new/

https://reviews.llvm.org/D135162



More information about the Openmp-commits mailing list