[Openmp-commits] [PATCH] D102000: [libomptarget] Add support for target memory allocators to cuda RTL
George Rokos via Phabricator via Openmp-commits
openmp-commits at lists.llvm.org
Thu May 6 10:50:48 PDT 2021
grokos accepted this revision.
grokos added a comment.
This revision is now accepted and ready to land.
Looks good (with one naming nit)
================
Comment at: openmp/libomptarget/plugins/cuda/src/rtl.cpp:301
const std::vector<DeviceDataTy> &DeviceData;
+ std::unordered_map<void *, TargetAllocTy> AllocKinds;
----------------
Can you rename `AllocKinds` to something like `HostPinnedAllocs`? `AllocKinds` does not make sense anymore after the latest change.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D102000/new/
https://reviews.llvm.org/D102000
More information about the Openmp-commits
mailing list