[Openmp-commits] [PATCH] D105767: [OpenMP] Simplify variable sharing and increase shared memory size

Johannes Doerfert via Phabricator via Openmp-commits openmp-commits at lists.llvm.org
Sun Jul 11 16:34:47 PDT 2021


jdoerfert added inline comments.


================
Comment at: openmp/libomptarget/deviceRTLs/common/src/data_sharing.cu:156
+  if (nArgs <= NUM_SHARED_VARIABLES_IN_SHARED_MEM) {
+    _SharedMemVariableSharingSpacePtr = &_SharedMemVariableSharingSpace[0];
+  } else {
----------------
tianshilei1992 wrote:
> but I don't like the name…Starting with `_` is not a typical LLVM name.
I will use `static` and remove the `_`


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D105767/new/

https://reviews.llvm.org/D105767



More information about the Openmp-commits mailing list