[Openmp-commits] [PATCH] D95093: [libomptarget][devicertl] Drop templated atomic functions
Jon Chesterfield via Phabricator via Openmp-commits
openmp-commits at lists.llvm.org
Fri Jan 22 04:08:34 PST 2021
JonChesterfield added a comment.
I'd like to call the clang/llvm intrinsics instead, plus replace unsigned long long with uint64_t. Easier to check the correctness of that after the call sites are limited to one file.
It's probably also time to move the common parts of the two target_impl files to a header in common, will try to think of a good name for it.
================
Comment at: openmp/libomptarget/deviceRTLs/amdgcn/src/target_impl.hip:134
DEVICE int GetNumberOfBlocksInKernel() {
+ return get_grid_dim(__builtin_amdgcn_grid_size_x(),
----------------
tianshilei1992 wrote:
> This change seems unrelated.
Yeah, result of clang-format at file scope
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D95093/new/
https://reviews.llvm.org/D95093
More information about the Openmp-commits
mailing list