[Openmp-commits] [PATCH] D55078: Add omp_pause_resource* API
Andrey Churbanov via Phabricator via Openmp-commits
openmp-commits at lists.llvm.org
Wed Dec 5 09:41:56 PST 2018
AndreyChurbanov added inline comments.
================
Comment at: runtime/src/include/50/omp_lib.f.var:292
+ function omp_pause_resource(level, device)
+ use omp_lib_kinds
----------------
Parameters should be re-named as (kind, device_num). Because in Fortran user can provide named arguments, so we should use same names as in the specification.
================
Comment at: runtime/src/include/50/omp_lib.f.var:299
+
+ function omp_pause_resource_all(level)
+ use omp_lib_kinds
----------------
Parameter "level" should be renamed to "kind" to correspond to the specification.
================
Comment at: runtime/src/include/50/omp_lib.f90.var:308
+ function omp_pause_resource(level, device) bind(c)
+ use omp_lib_kinds
----------------
Parameters should be re-named as (kind, device_num). Because in Fortran user can provide named arguments, so we should use same names as in the specification.
================
Comment at: runtime/src/include/50/omp_lib.f90.var:315
+
+ function omp_pause_resource_all(level) bind(c)
+ use omp_lib_kinds
----------------
Parameter "level" should be renamed to "kind" to correspond to the specification.
================
Comment at: runtime/src/include/50/omp_lib.h.var:340
+ function omp_pause_resource(level, device) bind(c)
+ import
----------------
Parameters should be re-named as (kind, device_num). Because in Fortran user can provide named arguments, so we should use same names as in the specification.
================
Comment at: runtime/src/include/50/omp_lib.h.var:347
+
+ function omp_pause_resource_all(level) bind(c)
+ import
----------------
Parameter "level" should be renamed to "kind" to correspond to the specification.
Repository:
rOMP OpenMP
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D55078/new/
https://reviews.llvm.org/D55078
More information about the Openmp-commits
mailing list