[Openmp-commits] [PATCH] D38185: Implementation of OMPT as specified in OpenMP 5.0 Preview 1
Jonas Hahnfeld via Phabricator via Openmp-commits
openmp-commits at lists.llvm.org
Thu Oct 26 07:17:01 PDT 2017
Hahnfeld added a comment.
I think we are getting there :-) however, the current base for the diff looks old, can you update to the changes to `.clang-format` by @jlpeyton?
================
Comment at: runtime/src/kmp_tasking.cpp:1707
+ OMPT_STORE_RETURN_ADDRESS(gtid);
+ return __kmpc_omp_taskwait_template<true>(loc_ref, gtid, OMPT_GET_FRAME_ADDRESS(1),
+ OMPT_LOAD_RETURN_ADDRESS(gtid));
----------------
hbae wrote:
> I think the intention here was to call the outlined function __kmpc_omp_taskwait_ompt.
Oops, I must have missed that when I pushed my experimental changes to our internal GitLab...
================
Comment at: runtime/src/ompt-general.cpp:12
+#if KMP_OS_UNIX
+#include <execinfo.h>
+#include <dlfcn.h>
----------------
Do we need this include? D39182 removes it again
================
Comment at: runtime/src/ompt-general.cpp:124
+ ompt_start_tool_t next_tool = NULL;
+ *(void **)(&next_tool) = dlsym(RTLD_NEXT, "ompt_start_tool");
+ if (next_tool)
----------------
`next_tool = (ompt_start_tool_t)dlsym(RTLD_NEXT, "ompt_start_tool");` looks much more readable IMO
https://reviews.llvm.org/D38185
More information about the Openmp-commits
mailing list