[Openmp-commits] [PATCH] D33227: [OpenMP] libomptarget: move debugging dumps under control of environment variable OMP_TARGET_DEBUG

Jonas Hahnfeld via Phabricator via Openmp-commits openmp-commits at lists.llvm.org
Wed May 31 23:04:38 PDT 2017

Hahnfeld added a comment.

In https://reviews.llvm.org/D33227#769276, @sdmitriev wrote:

> I can change the name for this environment variable it as you suggested, but it will make it consistent with other environment variable's name that is already used by libomptarget - OMP_TARGET_OFFLOAD (look at openmp/libomptarget/src/omptarget.cpp, line 285).

I criticized that when the code went in. The convincing argument here was that `OMP_NUM_TEAMS` may be defined in a later version of the spec and `OMP_TARGET_OFFLOAD` was already used for some bots. As that's not yet true for `OMP_TARGET_DEBUG`, I would also prefer a different name. Ideally, we should also get rid of `OMP_TARGET_OFFLOAD` and rename it to something different...


More information about the Openmp-commits mailing list