[Openmp-commits] [PATCH] kmp_lock: Change return type of release functions from void to int
Hahnfeld at itc.rwth-aachen.de
Thu Apr 9 23:45:48 PDT 2015
In http://reviews.llvm.org/D8916#153774, @jcownie wrote:
> I think it would be cleaner if you defined the new constants as KMP_LOCK_RELEASED and KMP_LOCK_STILL_HELD, then the non-nested lock implementations can sensibly return KMP_LOCK_RELEASED, which would be preferable to the explicit "0" they return at the moment.
Good idea, have changed it locally and will be included in an updated revision (next week?)
More information about the Openmp-commits