[llvm-dev] Top-level .clang-tidy options and VariableName suggestion on CodingStandards

Nicolai Hähnle via llvm-dev llvm-dev at lists.llvm.org
Fri Aug 20 15:58:35 PDT 2021


First of all, thank you for pushing on this topic. I would agree that
UpperCamelCase naming style was a mistake.

[snip]

> > Further thought: I don't think (1) should proceed as-is no matter the
> decision on (2). We should have an LLVM umbrella naming convention (I don't
> think the number of projects that use one or the other should be a vote in
> favor or against - LLVM Core is still the core of the umbrella project and
> has more weight here than other subprojects (not the only thing that
> matters, but part of it), removing any naming convention I think would be
> unhelpful.
>
>> > & I don't think (2) should be "use either of these naming conventions"
>> it should be "this is the naming convention" perhaps with a note that LLVM
>> Core (& some other places, such as clang-tools-extra) uses a different one
>> for historical reasons, for instance.
>>
>
That sounds fair.



> There were debates about whether camelCase/snake_case should be used
>> for variable names,
>> Personally I am fine with either one but slightly prefer snake_case.
>> New projects using either form will be fine to me.
>>
>> For (1), I have some doubt whether there will be an LLVM umbrella
>> naming convention for variable names,
>> but I **don't** consider the lack of convergence (to either camelCase
>> or snake_case) an argument for keeping VariableName in the in the
>> top-level .clang-tidy .
>> Actually I strongly oppose to keeping VariableName in the top-level
>> .clang-tidy, or new projects adopting VariableName.
>>
>
> It's pretty important to me that we don't make it easier to create more
> divergence in naming conventions - creating another project that diverges
> from LLVM's naming conventions/creates more naming inconsistency seems like
> a loss to me. So until there's some buy-in for a desired future direction,
> I think new projects should adhere to the existing convention.
>
> I don't think that future direction must include a way to cleanup LLVM -
> as Chris Lattner said, maybe it is something like "Even if the community
> does not have the appetite to do a huge scale renaming of all the things in
> LLVM, it would be interesting to carve out an exception for new code being
> written, refactored, or potentially for use in new subprojects." - though I
> think that's a choice we should all make together (doesn't require it to be
> unanimous) and carefully. That does produce the inconsistent-with-LLVM-core
> issue I'm concerned about, but maybe with a path forward to consistency.
>
Might be worth talking about whether people would be comfortable with more
> active cleanup - not necessarily one huge renaming, but be willing to
> accept patches that rename things without necessarily being pieces of code
> being actively refactored for other reasons. That'd help alleviate the "now
> we're going to have N different conventions based on when a given
> subproject was introduced", which increases friction when moving between
> subprojects (as zturner pointed out in some of the discussion/code review
> of style changes proposed previously).
>

My view is that changes for purely stylistic reasons hurt *much* more than
switching between projects with different variable naming styles.

LLVM de facto very much has a distributed development model. Even teams
that work close to upstream often have their own branches where changes are
developed before they are ready for Phabricator. Style changes have a
tendency to introduce totally pointless merge failures. Anybody who is
proposing purely stylistic changes is *usually* proposing creating a lot of
busywork for a lot of people. It*s just not worth it.

(Sometimes, stylistic cleanups are truly confined to a single file. In that
case, they may be fine, especially when the file doesn't change very much
in the first place. As soon as you're changing names in header files,
though, you're very likely going to cause problems.)

*Mandating* a move away from UpperCamelCase for *new* code, and *allowing*
(or perhaps *suggesting*) renames away from UpperCamelCase for code that is
being refactored anyway, is the way to go in my opinion.

Cheers,
Nicolai



> - Dave
> _______________________________________________
> LLVM Developers mailing list
> llvm-dev at lists.llvm.org
> https://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
>


-- 
Lerne, wie die Welt wirklich ist,
aber vergiss niemals, wie sie sein sollte.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20210821/e69dcab0/attachment.html>


More information about the llvm-dev mailing list