[llvm-dev] RFC: [SmallVector] Adding SVec<T> and Vec<T> convenience wrappers.

Chris Lattner via llvm-dev llvm-dev at lists.llvm.org
Sat Dec 5 08:46:26 PST 2020

> On Dec 3, 2020, at 10:45 AM, Sean Silva <chisophugis at gmail.com> wrote:
>> I'll try to get a minimal patch together with docs and send an RFC later this week.
>> (
>> I think the initial patch could be as simple as:
>> ```
>> template <class T> using Vector = SmallVector<T, 0>;
>> ```
>> but maybe we'd want to rename `SmallVectorImpl` to `VectorImpl`, or maybe there are other ideas, but off topic for this thread...
>> )
> Right, I think it is as simple as the using declaration, but also includes a revision to the coding standards and programmer manual dox.
> I do think that renaming SmallVectorImpl to VectorImpl would make sense, that is something we can stage in over time (introduce the alternate name, rename everything in tree, then drop the old name in a few months).
> And we can drop the "Impl", since it is a type intended to be used by users :)

I’m not opposed to renaming the Impl suffix to something better, but I don’t think we can make “Vector" == VectorImpl.  Can we?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20201205/786ea57d/attachment-0001.html>

More information about the llvm-dev mailing list