[llvm-dev] RFC: changing variable naming rules in LLVM codebase
Chandler Carruth via llvm-dev
llvm-dev at lists.llvm.org
Mon Feb 25 14:47:09 PST 2019
On Mon, Feb 25, 2019 at 7:17 AM David Greene via llvm-dev <
llvm-dev at lists.llvm.org> wrote:
> <paul.robinson at sony.com> writes:
> >> "lower_case" is a pretty drastic change from CamelCase and camelCase.
> >> So far the only argument for it I've seen is, "lldb uses it all over the
> >> place." Having one subproject drive the standard for everything else
> >> seems backward. It's certainly possible I missed other opinions on this
> >> though.
> > You have. For example, here's a "significant improvement" comment:
> > http://lists.llvm.org/pipermail/llvm-dev/2019-February/130214.html
> But I see nothing there about *why* it would be a "significant
> improvement." At best I see an allusion to something like, "this is
> really different than anytyhing we've done before so it doesn't conflict
> with any existing naming." If I've misinterpreted I hope Chandler will
> correct me.
I wrote more details on this thread about why I significantly prefer this.
Can you respond there? I don't want to just repeat things that already make
sense or miss the things that actually don't make sense.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-dev