[llvm-dev] changing variable naming rules in LLVM codebase

David Greene via llvm-dev llvm-dev at lists.llvm.org
Wed Feb 13 06:57:27 PST 2019

Chandler Carruth <chandlerc at gmail.com> writes:

> FWIW, I'm pretty strongly opposed to humbleCamelCase. We already use
> that style so something else. One of the biggest advantages of
> changing the variable naming convention would be to differentiate
> variables from other constructs IMO, and that's the nature of many
> examples here.

I guess I don't see a lot of point to being different for difference's
sake.  Functions use humbleCamelCase but it's fairly easy to
differentiate a function from a variable at the point of use, unless one
is referencing a function's address in which case it kinda is like a
variable in that context.

humbleCamelCase also has the advantage of removing the weird special
case for lambdas, where in one sense it's a function and in another
sense it's a variable.

What are the current uses of humbleCamelCase that concern you?

In the end I don't really care what the convention is.  I'm not sure a
mechanical updating of the source is worth it, as that can make using
git blame slightly inconvenient.


More information about the llvm-dev mailing list