[llvm-dev] RFC: should we spell lambdas like functions?

Lang Hames via llvm-dev llvm-dev at lists.llvm.org
Fri Jul 13 20:08:07 PDT 2018


>
> - Use lowerCamelCase.
>
>
FWIW I would prefer to name them like variables too. Since being callable
is their raison d'etre I'm unlikely to forget to use them that way. On the
other hand, naming them like variables is a subtle but helpful reminder
that they can be assigned to, moved from, may be default constructed (and
so in a not-callable state), etc.

Cheers,
Lang.

On Wed, Jul 11, 2018 at 3:39 AM Chandler Carruth via llvm-dev <
llvm-dev at lists.llvm.org> wrote:

> On Thu, Jul 5, 2018 at 12:57 PM Duncan P. N. Exon Smith via llvm-dev <
> llvm-dev at lists.llvm.org> wrote:
>
>> I argue we should spell C++ lambdas (and other function-like variables)
>> like functions, not like variables.
>>
>> - Use verbs, not nouns.
>>
>
> Totally agree.
>
>
>> - Use lowerCamelCase.
>>
>
> Really disagree.
>
> I don't like having two different case conventions for variables. They're
> all variables, and I think they should be named using the same convention.
>
>
>>
>> Here's a patch that implements the change to the coding standards:
>> https://reviews.llvm.org/D48991
>>
>> Thoughts?
>> _______________________________________________
>> LLVM Developers mailing list
>> llvm-dev at lists.llvm.org
>> http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
>>
> _______________________________________________
> LLVM Developers mailing list
> llvm-dev at lists.llvm.org
> http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20180713/27a39ca9/attachment.html>


More information about the llvm-dev mailing list