[llvm-dev] LLC Version 3.8 : Unsupported library call operation for a mul instruction

div code via llvm-dev llvm-dev at lists.llvm.org
Sun Dec 16 08:47:10 PST 2018

Hello List,

I am on the hook to instrument a piece of legacy LLVM IR code, and then we
are planning to feed to the SeaHorn framework for some model checking tasks.

After the instrumentation, I tried to use llc (version 3.9) to compile the
IR code, and it works fine. However, when I try to use llc (version 3.8.1,
the default llvm version of SeaHorn) to compile the IR code, it shows the
following error:

LLVM ERROR: Unsupported library call operation!

I tried to do some "delta debugging" and eventually locate the buggy line
of the code. So as shown below, the following code cause llc (version
3.8.1) throws the "Unsupported library call operation" issue, but it works
fine for llc version 3.9.

  %20 = call i256 @llvm.bswap.i256(i256 %msg.value)
  %21 = mul i256 %20, 190

I tried to tweak the buggy lines into the following code, and it can also
pass the compilation:

  %20 = call i256 @llvm.bswap.i256(i256 %msg.value)
  %21 = add i256 %20, 190

This seems really wired to me.. Any idea on that? Thank you!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20181216/04257b7d/attachment.html>

More information about the llvm-dev mailing list