[llvm-dev] Problem with 'sed' on one Windows bot?

Robinson, Paul via llvm-dev llvm-dev at lists.llvm.org
Thu Nov 9 10:27:49 PST 2017

Thanks, Galina.  It doesn't explain why the test worked on some bots but not this one, but Justin's workaround is okay with me.

From: Galina Kistanova [mailto:gkistanova at gmail.com]
Sent: Thursday, November 09, 2017 10:09 AM
To: Robinson, Paul
Cc: Davide Italiano; llvm-dev at lists.llvm.org
Subject: Re: [llvm-dev] Problem with 'sed' on one Windows bot?

There is nothing wrong with the bot.

>sed --version
sed (GNU sed) 4.2.2
It works just fine when I run the exact command in question manually from the shell.
As Justin has suggested, the problem lies somewhere in LIT in how it processes the arguments from input file to a shell execution.

On Tue, Nov 7, 2017 at 3:22 PM, Robinson, Paul <paul.robinson at sony.com<mailto:paul.robinson at sony.com>> wrote:
As Davide suggests, most likely it's a bot software installation snafu.
But the simpler sed script works perfectly, and I'll do that for now.

I had understood that LLVM expected people to install GnuWin32, but
maybe it's not sufficiently well specified about versions and whatnot.

> -----Original Message-----
> From: davide.italiano at gmail.com<mailto:davide.italiano at gmail.com> [mailto:davide.italiano at gmail.com<mailto:davide.italiano at gmail.com>] On
> Behalf Of Davide Italiano
> Sent: Tuesday, November 07, 2017 3:10 PM
> To: Robinson, Paul; Galina Kistanova
> Cc: llvm-dev at lists.llvm.org<mailto:llvm-dev at lists.llvm.org>
> Subject: Re: [llvm-dev] Problem with 'sed' on one Windows bot?
> On Tue, Nov 7, 2017 at 2:41 PM, Robinson, Paul via llvm-dev
> <llvm-dev at lists.llvm.org<mailto:llvm-dev at lists.llvm.org>> wrote:
> > A test I added in r317607 is passing almost everywhere, except for
> > llvm-clang-x86_64-expensive-checks-win.  Other Windows bots are happy.
> >
> > http://lab.llvm.org:8011/builders/llvm-clang-x86_64-expensive-checks-
> win/builds/6013
> >
> > The test runs 'sed' on a file to generate variations of the input
> > assembler source for Linux and Darwin.  I have to say it looks like
> > 'sed' is being the problem on that one bot.  I reverted the test
> > because "don't argue with the bots" but... but... "It's not my fault!"
> >
> > If anybody has any insight it would be greatly appreciated.
> > Thanks,
> > --paulr
> >
> The short answer is that Galina should install the correct version of
> `sed` (presumably from gnuwin32) on that bot.
> The somewhat longer answer is that you could work around as Justin
> suggested, but I'm not sure what's your sed foo and/or whether it's
> worth going that route.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20171109/afdd7813/attachment.html>

More information about the llvm-dev mailing list