[LLVMdev] TableGen Style Conventions
mmcco at mykolab.com
mmcco at mykolab.com
Sat May 30 21:07:31 PDT 2015
This probably qualifies as bikeshedding, but how strict are the style
norms for TableGen? Some aspects of it, like individually and
consecutively declaring all *_ENC variables in this manner:
class ADDU_QB_ENC : ADDU_QB_FMT<0b00000>;
To be used only once, in this manner:
def ADDU_QB : ADDU_QB_ENC, ADDU_QB_DESC;
Seem like avoidable clutter to me. The files tend to be pretty big, and
I think that collapsing assignments like that could make them more
readable.
I'm new to this, so let me know if I'm missing something.
Thanks,
Michael
More information about the llvm-dev
mailing list