[LLVMdev] AliasAnalysis refactoring for the new pass manager
Chandler Carruth
chandlerc at gmail.com
Mon Jun 15 16:29:49 PDT 2015
On Mon, Jun 15, 2015 at 3:56 PM Duncan P. N. Exon Smith <
dexonsmith at apple.com> wrote:
> I like this colour:
>
> enum class AliasKind /* or AliasCategory? */ {
> Null,
> Unknown,
> Partial,
> Complete
> };
>
So, the only non-bikeshed-color argument I have (which is also referenced
by Philip, but i couldn't reply to both) suggests we *really* want NoAlias,
MayAlias, and MustAlias, because these are terms of art in the literature
(confirmed by DannyB who is a reasonable expert in alias analysis
literature). I'm inclined to keep these names as a consequence. The natural
extension is PartialAlias.
That leaves the question of the enumeration name. I think "AliasResult" is
my new found favorite. Danny gave me a reason: these are really results of
a particular query, not just abstract kinds of aliasing... And its shorter
than AliasRelationship. =]
Thoughts?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20150615/7b071f44/attachment.html>
More information about the llvm-dev
mailing list