[llvm-dev] [RFC] Intrinsic naming convention (words with dots)
Bruce Hoult via llvm-dev
llvm-dev at lists.llvm.org
Tue Dec 1 11:19:38 PST 2015
So then that leaves camelCase for words in a context...
On Tue, Dec 1, 2015 at 9:34 PM, David Chisnall via llvm-dev <
llvm-dev at lists.llvm.org> wrote:
> On 1 Dec 2015, at 17:15, Krzysztof Parzyszek via llvm-dev <
> llvm-dev at lists.llvm.org> wrote:
> > How about using dots to separate "contexts" and underscores to separate
> words, e.g.
> > llvm.gc.* --stuff related to GC
> > llvm.gc.read
> > llvm.gc.do_something_else
> My concern with this proposal is that the process that generates the C++
> enum values transforms dots into underscores. Mixing dots and underscores
> in the IR seems really bad because there are then multiple possible IR
> values for any given C++ value. I’d much prefer that we remove the
> existing users to underscores and make it explicit that dot in IR means
> underscore in C++.
> LLVM Developers mailing list
> llvm-dev at lists.llvm.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-dev