[LLVMdev] LLD: Returning true on success

Michael Spencer bigcheesegs at gmail.com
Tue Sep 24 12:40:57 PDT 2013


On Tue, Sep 24, 2013 at 12:33 PM, Rui Ueyama <ruiu at google.com> wrote:

> Hi LLD developers,
>
> I'm about to make a change to invert the return value of Driver::parse()
> to return true on success. Currently it returns false on success.
>
> In many other functions, we return true to indicate success and false to
> indicate failure. The inconsistency is confusing, and fixing it should
> improve code readability.
>
>
Note that some places in LLVM use false to indicate success, not sure how
widespread this is. Personally I think that { if (doSomething()) } means if
doSomething succeeded, and thus agree with you. However, I think this is
something that needs to be consistent across all of LLVM and should be in
the coding standard.

- Michael Spencer
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20130924/c0a994ef/attachment.html>


More information about the llvm-dev mailing list