[LLVMdev] help with llvm make system

Stefan Oestreicher stefan.oestreicher at deluxe-design.at
Wed Sep 23 03:13:14 PDT 2009


I still have this problem. I now removed the library so the project just
consists of one tool but still no joy. The makefile looks like this:

--- snip ---

LINK_COMPONENTS := support system

include $(LEVEL)/Makefile.common

CFLAGS += -I/usr/local/include -x c++
CXXFLAGS += -I/usr/local/include
LDFLAGS += -L/usr/local/lib -lantlr3c
--- /snip ---

I don't get why it compiles a library without problems but chokes at the
tool. I also tried to set the LLVMLIBS variable in all kinds of
variations but this didn't seem to have any effect at all.

I also tried to compile manually with
g++ -g tools/lomoc/main.cc `llvm-config --cxxflags --ldflags --libs
core` -o lomoc.exe
but this generates the same errors.

I'd very much appreciate it if someone could point me into the right
direction as I'm stumped and don't know what else to try.



More information about the llvm-dev mailing list