[LLVMdev] llc and debug information

Nick Jalbert jalbert at eecs.berkeley.edu
Fri Sep 18 15:10:51 PDT 2009

Figured out my problem, mailing the list in case anyone else runs into the
same issue.  I had updated the LLVM tools to the svn version, but not the
front end.  It seems that debugging information is handled differently with
the latest version of the tools (perhaps as a result of this
 I ended up grabbing a prerelease of llvm2.6 found
and building both the front end and the LLVM tools from source.  Using tools
from a consistent period in time solved my problem--oops!
Thanks to everyone who tried to help out :).


On Thu, Sep 17, 2009 at 2:20 AM, Duncan Sands <baldrick at free.fr> wrote:

> Nick Jalbert wrote:
>> Thanks for the quick responses, but unfortunately still no luck:
>>  > llvm-g++ -g -O0 -c -emit-llvm test.cpp
>>  > llc -O0 test.o
>>  > g++ test.o.s
>>  > ./a.out My return address is 0x400bb2
>>  > addr2line 0x400bb2
>> ??:0
>> Also to further implicate llc, this works:
>>  > llvm-g++ -g -O0 -S test.cpp  > g++ test.s  > ./a.out My return address
>> is 0x400bf9
>>  > addr2line 0x400bf9
>> /home/jalbert/llvmtest//test.cpp:13
>> Anymore thoughts?
> maybe try passing -disable-fp-elim to llc?
> Ciao,
> Duncan.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20090918/c8acc225/attachment.html>

More information about the llvm-dev mailing list