[LLVMdev] Generatin code for an ARM-LINUX machine

Juan Carlos Martinez Santos juanc.martinez.santos at gmail.com
Wed Jul 1 12:01:54 PDT 2009

Hello Misha,

I used the snapshots for the latest stable version (70786), and I followed
the instructions inside of README file (very clear!!!)

However, when I ran the hello program, I get an unrecognized option message.
Bellow are the details.

jcmartin78 at jcmartin78-laptop:~/LLVM/my-test$ llvmc hello.c
as: unrecognized option '-meabi=4'

More details:
jcmartin78 at jcmartin78-laptop:~/LLVM/my-test$ llvm-gcc -v hello.c -o hello
Using built-in specs.
Target: arm-none-linux-gnueabi
Configured with: /tmp/llvm-project.jnnWEq/src/llvm-gcc-4.2/configure
--program-prefix=llvm- --target=arm-none-linux-gnueabi
Thread model: posix
gcc version 4.2.1 (Based on Apple Inc. build 5645) (LLVM build)
-quiet -v hello.c -quiet -dumpbase hello.c -auxbase hello -version -o
ignoring nonexistent directory
#include "..." search starts here:
#include <...> search starts here:
End of search list.
GNU C version 4.2.1 (Based on Apple Inc. build 5645) (LLVM build)
    compiled by GNU C version 4.3.3.
GGC heuristics: --param ggc-min-expand=150 --param ggc-min-heapsize=131072
Compiler executable checksum: 41625b7e939f94061601f66e8d27b606
 as -meabi=4 -o /tmp/ccYxnIEs.o /tmp/ccy6iYri.s
as: unrecognized option '-meabi=4'

This is my PATH:

Any idea what could be wrong?

Thanks in advance,

Juan Carlos

On Wed, Jul 1, 2009 at 9:53 AM, Misha Brukman <brukman at gmail.com> wrote:

> 2009/6/30 Juan Carlos Martinez Santos <juanc.martinez.santos at gmail.com>
>> Thanks John,
>> I just realized that I am not working on the same "branch" of LLVM.
>> Looking the latest or the newest version I saw the folder with the script,
>> but I did not see a README file.
>> I ran the script, and I get:
>> **********
>> chown: cannot access `/usr/local/codesourcery': No such file or directory
>> **********
> You should have an error prior to this one where the script first tried to
> create the directory "/usr/local/codesourcery", after which it tries to
> chown it.  Can you post the entire output of the script rather than the last
> line?
>> Therefore my question is if the script depends on others folders (or
>> files) that maybe are not in the 2.5 version.
> The script does depend on files that are not distributed in LLVM.  I just
> added a README file to describe what needs to be done and how:
> http://llvm.org/svn/llvm-project/llvm/trunk/utils/crosstool/ARM/README .
> Let me know if this helps or if it's not clear.
> Misha
> _______________________________________________
> LLVM Developers mailing list
> LLVMdev at cs.uiuc.edu         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev

Juan Carlos Martínez Santos
242 Foster Drive Apt H
Colonial Townhouse Apartments
Willimantic, CT 06226-1538
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20090701/4ef185ae/attachment.html>

More information about the llvm-dev mailing list