[LLVMdev] DEBUG
Chris Lattner
sabre at nondot.org
Mon Jul 7 13:57:25 PDT 2008
On Mon, 7 Jul 2008, David Greene wrote:
>> Since I think it really is a part of the LLVM internals, I don't think
>> that mangling it with a prefix is the right way to go. This would
>> significantly increase verbosity in the code and would be generally
>> detrimental.
>
> Verbose, yes, but "generally detrimental?" That's a pretty strong statement.
More specifically, this impacts the tyranical :) 80 column limit we have:
DEBUG(cout << "whatever stuff here" << yeah << "ok");
is much more clear to me than:
LLVM_DEBUG(cout << "whatever stuff here"
<< yeah << "ok");
To be specific, excess wrapping and clutter is what I would find
detrimental.
-Chris
--
http://nondot.org/sabre/
http://llvm.org/
More information about the llvm-dev
mailing list