[LLVMdev] problem loading analysis results from Inliner pass

Michael McCracken michael.mccracken at gmail.com
Mon Mar 20 23:06:52 PST 2006

Hi, I'm trying to access an analysis pass from the Inliner pass, and
I'm having a lot of trouble getting that to work - I can verify that
my pass is loaded and run (it is a dynamically loaded pass that is
part of an analysisgroup), however, when I access it using
getAnalysis<> from within Inliner::runOnSCC, I am instead getting the
default, dummy version of my analysis, which should be overridden by
the one that was brought in with -load.

I'm having a hard time debugging this, so any tips for how to track
the problem down would be appreciated.

I am running on Linux, and the version of LLVM I am working with is
from CVS a couple of months ago, so if this sounds like a problem
that's been solved already, it might be - that'd be good news.

This arrangement of analysis passes has worked in the past, and the
fact that my pass is loaded but not resolved correctly leads me to
believe it isn't a platform issue, but I'm open to any suggestions.

Thanks, and let me know if any more details would be helpful,

Michael McCracken
UCSD CSE PhD Candidate
research: http://www.cse.ucsd.edu/~mmccrack/
misc: http://michael-mccracken.net/wp/

More information about the llvm-dev mailing list