[LLVMdev] Leading spaces in Makefile.rules

Chris Lattner sabre at nondot.org
Wed Mar 1 11:20:45 PST 2006

On Tue, 28 Feb 2006, Wink Saville wrote:
> Last night I checked out the head of CVS and tried to compile after 
> configuring with:
> ./configure --enable-debug-runtime --enable-jit --prefix=/opt/lvm-cvs
> I then got a message indicating that Line 1099 of Makefile.rules has 8 
> leading spaces instead of a tab, I fixed that and then the build completed, 
> although there were 6 warnings (http://www.saville.com/llvm/make1.out).

Fixed, thanks.

> Reid suggested here 
> (http://lists.cs.uiuc.edu/pipermail/llvmdev/2006-February/005261.html) that I 
> install new runtime bytecodes. I did and then did:
>   make clean ; make
> And got 4 warnings here (http://www.saville.com/llvm/make2.out).
> Maybe the warnings are normal, just thought I'd report them. Also, my 
> computer is a Amd64 runing X86-64 linux (Ubuntu 5.10). The compiler is 4.0.2 
> and glibc version appears to be 2.3.5.

They are normal.

> My intent is to track down why I was getting crtend not found when using 
> llvm-ld in my simple test app as I mentioned in the other thread, and then to 
> see it occur in the full build was strange, so I haven't tried to run what I 
> built.

I'm not sure, maybe Reid has some ideas (llvm-ld is his).



More information about the llvm-dev mailing list