[llvm] 22f70cb - [gn] Rename sync_source_dir.py to just sync_dir.py (#196059)

via llvm-commits llvm-commits at lists.llvm.org
Wed May 6 05:55:49 PDT 2026


Author: Nico Weber
Date: 2026-05-06T08:55:44-04:00
New Revision: 22f70cb328e2cb718ba72ec3796b11e44d546266

URL: https://github.com/llvm/llvm-project/commit/22f70cb328e2cb718ba72ec3796b11e44d546266
DIFF: https://github.com/llvm/llvm-project/commit/22f70cb328e2cb718ba72ec3796b11e44d546266.diff

LOG: [gn] Rename sync_source_dir.py to just sync_dir.py (#196059)

No behavior change.

Added: 
    llvm/utils/gn/build/sync_dir.py

Modified: 
    llvm/utils/gn/secondary/libcxx/include/BUILD.gn

Removed: 
    llvm/utils/gn/build/sync_source_dir.py


################################################################################
diff  --git a/llvm/utils/gn/build/sync_source_dir.py b/llvm/utils/gn/build/sync_dir.py
similarity index 100%
rename from llvm/utils/gn/build/sync_source_dir.py
rename to llvm/utils/gn/build/sync_dir.py

diff  --git a/llvm/utils/gn/secondary/libcxx/include/BUILD.gn b/llvm/utils/gn/secondary/libcxx/include/BUILD.gn
index 797cdccfe33a3..e9e1b5e155ed0 100644
--- a/llvm/utils/gn/secondary/libcxx/include/BUILD.gn
+++ b/llvm/utils/gn/secondary/libcxx/include/BUILD.gn
@@ -76,7 +76,7 @@ if (current_toolchain == default_toolchain) {
   }
 
   action("copy_headers") {
-    script = "//llvm/utils/gn/build/sync_source_dir.py"
+    script = "//llvm/utils/gn/build/sync_dir.py"
     inputs = [
       "__algorithm/adjacent_find.h",
       "__algorithm/all_of.h",


        


More information about the llvm-commits mailing list