[PATCH] D158623: [RISCV] Reorder the stack frame objects.
lcvon via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Sep 1 01:05:39 PDT 2023
lcvon007 added inline comments.
================
Comment at: llvm/lib/Target/RISCV/RISCVFrameLowering.cpp:1505
+ // callee size.
+ if (STI.is64Bit() && CanCompress(496))
+ return 496;
----------------
reames wrote:
> This looks like a separate change, and should probably be it's own review with it's own tests.
>
> Also, magic constants are bad. Why can't this be written in terms of StackAlign just like the non-compressed case just below?
remove it, and I will submit another commit for it.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D158623/new/
https://reviews.llvm.org/D158623
More information about the llvm-commits
mailing list