[PATCH] D159221: [RFC] Alterative to https://reviews.llvm.org/D159169
Lei Wang via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Aug 31 12:31:02 PDT 2023
wlei added a comment.
In D159221#4632279 <https://reviews.llvm.org/D159221#4632279>, @wenlei wrote:
> Thanks for attempting the clean up. I think the original version is probably more readable. I left comments there. wdyt?
Sounds good, abandoning this, will work on the original patch.
================
Comment at: llvm/lib/Transforms/IPO/SampleProfile.cpp:2131
+ } else if (const auto *CB = dyn_cast<CallBase>(&I)) {
+ if (isa<IntrinsicInst>(&I))
+ return CalleeName;
----------------
wenlei wrote:
> I guess you want to exclude debug or probe instrinsics, but I'm still not sure if we should exclude all intrinsics. `llvm.memcpy` is also an intrinsic, but is probably still a good anchor?
It should be ok to exclude all the IntrinsicInst because this is consistent with the sample loader/inliner, I did a search, it looks in inliner we all have the ` if (isa<IntrinsicInst>(CB)) continue;` right after the `auto *CB = dyn_cast<CallBase>(&I);`.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D159221/new/
https://reviews.llvm.org/D159221
More information about the llvm-commits
mailing list