[PATCH] D157615: [ExtendLifetimes][1/4] Add "disable-post-ra" function attribute to disable the post-regalloc scheduler

Stephen Tozer via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Aug 25 08:37:26 PDT 2023


StephenTozer added inline comments.


================
Comment at: llvm/lib/CodeGen/PostRASchedulerList.cpp:282
 
+  if (Fn.getFunction().hasFnAttribute("disable-post-ra"))
+    return false;
----------------
Orlando wrote:
> bikeshed: `disable-post-ra` seems potentially unclear. Perhaps `disable-post-ra-sched`?
SGTM in principle, but it's worth noting that the flag to disable the post-RA scheduler is `-disable-post-ra`, so there's an argument that it would be more consistent to make the attribute and command line flag with identical functionality have the same name. I'm not attached to either side though, what do you think?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D157615/new/

https://reviews.llvm.org/D157615



More information about the llvm-commits mailing list