[PATCH] D157005: [mlir][ArmSME] Add move vector to tile slice op and lowerings

Cullen Rhodes via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Aug 24 02:27:50 PDT 2023


c-rhodes updated this revision to Diff 553048.
c-rhodes retitled this revision from "[mlir][ArmSME] Add vector to tile slice op and lowerings" to "[mlir][ArmSME] Add move vector to tile slice op and lowerings".
c-rhodes edited the summary of this revision.
c-rhodes added a comment.

Rename `vector_to_tile_slice` to `move_vector_to_tile_slice`


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D157005/new/

https://reviews.llvm.org/D157005

Files:
  mlir/include/mlir/Dialect/ArmSME/IR/ArmSME.td
  mlir/lib/Conversion/VectorToArmSME/VectorToArmSME.cpp
  mlir/lib/Dialect/ArmSME/Transforms/LegalizeForLLVMExport.cpp
  mlir/test/Dialect/ArmSME/arith-ops-to-sme.mlir
  mlir/test/Dialect/ArmSME/invalid.mlir
  mlir/test/Dialect/ArmSME/roundtrip.mlir
  mlir/test/Integration/Dialect/Vector/CPU/ArmSME/tile_fill.mlir

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D157005.553048.patch
Type: text/x-patch
Size: 20429 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20230824/c9e09fde/attachment.bin>


More information about the llvm-commits mailing list