[PATCH] D156467: [mlir][ArmSME] Add conversion from ArmSME to SCF to materialize loops

Frank (Fang) Gao via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Jul 28 11:06:15 PDT 2023


WanderAway added inline comments.


================
Comment at: mlir/include/mlir/Dialect/ArmSME/IR/ArmSME.td:311
 
+def TileSliceLoadAndUpdateOp : ArmSME_Op<"tile_slice_load_and_update", [
+    TypesMatchWith<"expected result type to match tile type",
----------------
I feel like the name is a bit confusing, although I'm not sure I can come up with something better...
`LoadTileSlice`? `LoadVectorToTile`?

Also I wonder if it makes sense for this to have a horizontal/vertical load variant/argument, so that it would be possible to do in-flight transpose as well?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D156467/new/

https://reviews.llvm.org/D156467



More information about the llvm-commits mailing list