[PATCH] D156444: [llvm][IR]
Nikita Popov via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jul 27 09:05:12 PDT 2023
nikic added a comment.
Missing LangRef change.
`was_sext` is the wrong name for this flag, because it's not meaningful in terms of operational semantics of the IR. You'll want to call this something like `nneg` or `nonneg`, with the semantics that if the argument is negative, the return value is `poison`. This allows refining `zext nneg %x` to `sext %x`.
Generally I'm on board with adding such a flag.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D156444/new/
https://reviews.llvm.org/D156444
More information about the llvm-commits
mailing list