[PATCH] D146648: [MLIR][OpenMP] Added MLIR translation support for use_device clauses

Akash Banerjee via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Jul 21 06:20:05 PDT 2023


TIFitis marked 2 inline comments as done.
TIFitis added inline comments.


================
Comment at: mlir/lib/Target/LLVMIR/Dialect/OpenMP/OpenMPToLLVMIRTranslation.cpp:1409
+    if (!mapOp.getType().isa<LLVM::LLVMPointerType>())
+      return failed();
 
----------------
kiranchandramohan wrote:
> failure()?
I was calling the `failed()` functor defined above. I've renamed it to `fail` to avoid confusion.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D146648/new/

https://reviews.llvm.org/D146648



More information about the llvm-commits mailing list