[PATCH] D154734: [WebAssembly] Report error for inline assembly with unsupported opcodes

Bryan Chan via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jul 10 07:58:17 PDT 2023


bryanpkc added inline comments.


================
Comment at: llvm/test/CodeGen/WebAssembly/inline-asm-failure.ll:2
+;RUN: not llc -O0 --mtriple=wasm32 -filetype=obj \
+;RUN:     -o /dev/null 2>&1 <%s | FileCheck %s
+source_filename = "issue111471.c"
----------------
NIT: Can you add a space between the semi-colon and `RUN:`? Same thing for the `;CHECK:` line below.


================
Comment at: llvm/test/CodeGen/WebAssembly/inline-asm-failure.ll:3
+;RUN:     -o /dev/null 2>&1 <%s | FileCheck %s
+source_filename = "issue111471.c"
+target datalayout = "e-m:e-p:32:32-p10:8:8-p20:8:8-i64:64-n32:64-S128-ni:1:10:20"
----------------
It might be useful to rename this to `"rust-issue-111471.c"`.


================
Comment at: llvm/test/CodeGen/WebAssembly/inline-asm-failure.ll:29
+!0 = !{i32 1, !"wchar_size", i32 4}
+!1 = !{!"clang version 16.0.5 (https://github.com/rust-lang/llvm-project.git 22897bce7bfedc9cd3953a33419b346936263500)"}
+!2 = !{i64 32}
----------------
Can you remove `!0` and `!1`, as well as `!llvm.module.flags` and `!llvm.ident`? These metadata are irrelevant to the test case. Rename `!2` to `!0`.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D154734/new/

https://reviews.llvm.org/D154734



More information about the llvm-commits mailing list