[PATCH] D152157: [AppleAccelTable] Keep track of the size of each hash data entry

Felipe de Azevedo Piovezan via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jun 5 13:35:54 PDT 2023

fdeazeve added a comment.

In D152157#4396561 <https://reviews.llvm.org/D152157#4396561>, @dblaikie wrote:

> Is this parsing code used for the standardized `.debug_names` too
>> , and do we (LLVM itself, and maybe GCC too) generally produce fixed size records there?

Nope, this code is for apple tables only; the two kinds of tables only share a pure virtual class, but not any real implementation.

I want to look into how the debug_names work as well, but for now my goal is to bring LLVM to feature parity with the duplicate code found inside LLDB for apple tables, so that we can delete the (IMO) not as-good-looking code in LLDB :)

  rG LLVM Github Monorepo



More information about the llvm-commits mailing list