[PATCH] D146289: dwp section overflow checks
David Blaikie via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Jun 5 10:27:48 PDT 2023
dblaikie added a comment.
I'm a bit confused - wasn't D144565 <https://reviews.llvm.org/D144565> already committed? What's this then? Should this patch be abandoned now?
================
Comment at: llvm/lib/DWP/DWP.cpp:722-724
+ Error Err (sectionOverflowErrorOrWarning(
+ InfoSectionOffset, InfoSectionOffset + C.getLength32(), "debug_info"));
+ if (Err) {
----------------
(prefer `=` init over `()` init where both are valid, the former doesn't allow implicit conversions while the latter does - so seeing `=` can be easier to read because there's no explicit conversions (which can be more complicated/nuanced) to worry about) - and prefer declaring the variable in the smallest scope, including in the `if` condition where possible)
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D146289/new/
https://reviews.llvm.org/D146289
More information about the llvm-commits
mailing list