[PATCH] D150706: [LAA] Update MaxSafeDepDistBytes when non-unit stride

Alexey Bataev via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue May 16 13:42:31 PDT 2023


ABataev added inline comments.


================
Comment at: llvm/lib/Analysis/LoopAccessAnalysis.cpp:2003
   // both A and B could be vectorized by 2 iterations.
   MaxSafeDepDistBytes =
+      std::min(static_cast<uint64_t>(Distance / Stride), MaxSafeDepDistBytes);
----------------
Looks like variable name does not match its semantics anymore


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D150706/new/

https://reviews.llvm.org/D150706



More information about the llvm-commits mailing list