[PATCH] D150522: [LoongArch] Support CodeModel::Large codegen

Ben Shi via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon May 15 03:02:37 PDT 2023


benshi001 added inline comments.


================
Comment at: llvm/lib/Target/LoongArch/LoongArchExpandPseudoInsts.cpp:252
+          : DestReg;
+  Register TmpPart023 =
+      DestReg.isVirtual()
----------------
xen0n wrote:
> benshi001 wrote:
> > Why name it to `TmpPart023` rather than `TmpPart3` ? 
> The name is intended to convey that this temporary value contains the parts 0, 2, and 3 of the desired value (part 1 is loaded with `pcalau12i` to give PC-relative semantics). Which do you think is better, names like "TmpParts023" (notice the plural "parts"), or simpler names like just "TmpA" "TmpB" and "TmpC"?
Just my opinion, it would be better that the instruction name and its desitnation register name can be similar.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D150522/new/

https://reviews.llvm.org/D150522



More information about the llvm-commits mailing list