[PATCH] D146737: [AMDGPU] Trim zero components from buffer and image stores

Mateja Marjanovic via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed May 10 04:36:42 PDT 2023


matejam updated this revision to Diff 520957.
matejam added a comment.

Change the name from findDemandedElts to trimTrailingZerosInVector.
Remove some unnecessary dyn_casts.
Refactor and rebase.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D146737/new/

https://reviews.llvm.org/D146737

Files:
  llvm/lib/Target/AMDGPU/AMDGPUInstCombineIntrinsic.cpp
  llvm/test/Transforms/InstCombine/AMDGPU/amdgcn-intrinsics.ll
  llvm/test/Transforms/InstCombine/AMDGPU/amdgcn-simplify-image-buffer-stores.ll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D146737.520957.patch
Type: text/x-patch
Size: 25356 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20230510/6f8adaa1/attachment.bin>


More information about the llvm-commits mailing list